Toyota RAV4 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello All,
First time poster, My wife got a new car a little while ago so I am driving her old 2009 Rav4 V6 sport
We have had it about a year now 2nd owner, Just turned 148K miles, I have all the service records from the original owner, It was serviced at the dealer like clockwork, And I myself kept up on the maintenance.
It is very clean and runs great, About a month ago I noticed on cold start ups I started to hear the VVT cold start rattle so after researching all I can my question is.
If I don't get this taken care of can I expect longevity out of this motor? Anyone with high miles and or has had the rattle any length of time have any problems with it.

Thanks
Bill
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,729 Posts
Mine does it too. At almost 55K miles, I'm pretty sure it's normal for the V6.
 

·
Registered
Joined
·
123 Posts
Not sure if we are talking about the same issue. My 07 V6 Sport did the same thing. I had about 17X,000km on it. Intermittent but it was only on cold starts. Repairs on it was not cheap so I traded it for a 2012 Sport V6. Apparently the 2GR-FE until 2009 had that issue (Lexus included). The fix was to have the timing cam gears replaced as the pin locking the cam gears kept missing the hole.

If we're talking about the same thing, I would get it addressed ASAP before something catastrophic happens. Don't mean to freak you out or anything. I held off on mine for at least a year before I traded it. Repairs was going to be north of $3,000 for me. While they have the engine out, you might as well replace the 3 rear banks of spark plugs and coil packs. Keep the 3 coil packs for incase any of the front one wear out.

My 2012 does not make that sound at all and I believe they fixed the issue starting form 2010 on wards.
 
1 - 3 of 3 Posts
Top