Toyota RAV4 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Tired Mother with zero car knowledge here. Hoping you folks may be able to help me with an issue I'm having with my 2013 Rav4.

It has roughly 115,000kms on the clock. Has always been serviced within terms. No issues to date.

So today I jumped in my car, and went to press the ignition button. But being tired/in a rush etc I only half pressed it. I didn't hit it hard enough to actually start the car (no 'broom' sound lol) but a light on the dash popped up saying 'Engine Oil Pressure Low'.

My question - the driver's manual says to "Call your dealer right away", but do you think that is indeed the case, or has the light lit up only because of the fact that I only half-hit the ignition switch?

I've not seen this light before. And obviously with a baby in the back seat I don't want to drive it anywhere if there is a dangerous fault.

Thanks in advance folks :)
 

·
Registered
Joined
·
245 Posts
Try it again, jump back in and start it up. See if the light remains on after you have started it. Have a feeling it was just one of the many lights that come on before the car starts up. Our dash lights up like a Christmas tree before t starts. Then all the lights go away. If you start the Rav and the light remains on, contact your shop.
 

·
Registered
Joined
·
49 Posts
I had a Yaris with push start which used to lose its mind if the button was only half pushed or the foot slipped off the clutch before it started.

I'm pretty confident that if you haven't seen the message again you're good to go

Sent from my Nexus 6P using Tapatalk
 

·
Super Moderator
Joined
·
10,144 Posts
Until the engine is actually running the oil pressure light should be on. As mentioned you only have a problem if it stays on after the car starts.
 
  • Like
Reactions: Krista74

·
Registered
Joined
·
1,570 Posts
Until the engine is actually running the oil pressure light should be on. As mentioned you only have a problem if it stays on after the car starts.

What the Doctor said! :wink
 
  • Like
Reactions: Krista74

·
Registered
Joined
·
2 Posts
Discussion Starter #6
Thanks so much everyone!

I went back out this morning and gave it another crack. It started up just fine and there was no message on the display so it looks like it's all good. I really appreciate your responses.

Have a great day y'all!
 
1 - 6 of 6 Posts
Top