Toyota RAV4 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hello everyone - first post here, just bought my wife a 2007 Limited V6. Initially thought the washer pump wasn't working, but after more inspection today, it seems the pumps are reversed front to rear. Rear washer sprays the front and vice versa. It did have right front damage from an accident according to car fax, but no noticeable damage and drives perfect.


I assume that's where the pumps are, since the reservoir is there. If there are two pumps? Could this be as simple as tubes being swapped on pumps?


I didn't get the manual yet, but am very mechanically adept and didn't have time to tear apart the fender well yet.


I appreciate any insight- Thanks!


Pete
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Excellent! That is what I assumed. Looks like I know one thing I am doing next weekend.

Thanks!
 

·
Super Moderator
Joined
·
10,130 Posts
There are two pumps, front and rear attached to the reservoir, so it's a matter of switching hoses back to the correct pump.
The other posters can give you insight on how to reach the pumps.
When I checked mine I could hear two different sounds when squirting front & rear - thus two pumps so the hoses must be switched. Must be weird running the front wipers and squirting the rear window. :confused:

I took a look and could see where one hose went down toward the pumps but no sign of a second hose. Must be buried somewhere way down in the bottom front of the fender. Maybe you access it by removing the fender liner. Let us know where you find it & how it goes.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Just switched the hoses on the pumps this morning, very accessible inside the front right fender well - works perfect now. Thanks for the replies!

Pete
 
1 - 5 of 5 Posts
Top