Toyota RAV4 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
All,

Have a 2008 Rav4 2.4 with 141K miles .. engine was replaced by a previous owner so unsure on actual miles ..

A month ago cylinder 4 coded a misfire so that injector was replaced which solved that issue.

The car has been getting harder and harder to start over the last ~40 days, now it will not start at all ... it tries to fire when I crank it over but just will not start ..

When it did start, it had rough idle but once you started driving it seemed ok

Just before the no start problem ( afew days ago) it coded 300,302 and 303 - (misfires on 2 and 3) ..

So I replaced the remaining injectors (1-3) so they are all new now .. denso OEMs

I hear a faint humming sound in the engine bay in front of the engine by the radiator when the key on, not sure what that is ..

Is there a separate fuel filter on this year or is it in the tank with the fuel pump ? Wonder if that could be clogged ..

I checked spark and it looks good and plugs are new ..

Any suggestions are greatly appreciated !
 

·
Registered
Joined
·
1,660 Posts
Any suggestions are greatly appreciated !
I had a previous vehicle (non-Toyota) which had similar symptoms. It turned out the fuel pump was failing.

.
 

·
Registered
Joined
·
20 Posts
If it is on the left side of engine (when in front of car and looking right at it) and chirping it might be the waterpump. I had this on my Rav4 2007 last year. In front of engine by radiator... not sure.
 

·
Super Moderator
Joined
·
10,194 Posts
If it is on the left side of engine (when in front of car and looking right at it) and chirping it might be the waterpump. I had this on my Rav4 2007 last year. In front of engine by radiator... not sure.
Could be but wouldn't keep it from starting.
A fuel pressure test is the next step.
 
1 - 4 of 4 Posts
Top