Toyota RAV4 Forums banner

401 - 420 of 442 Posts

·
Registered
Joined
·
320 Posts
No LuckySixes, you cannot measure engine oil pressure with Techstream (or any other software tool)



The engine (at least the V6) has only a on/off type pressure switch (located near the oil drain plug) that it directly wired to the dash low oil pressure indicator light. To measure pressure, you need to remove the pressure switch and replace it with a pressure gauge.
Not true. When I installed my Pioneer NEX stereo with Imaestro, I'm able to see oil pressure on the screen. The information is there on the CAN bus somewhere if the stereo can display it. I don't know if techstream is set up for it though.
 

·
Registered
Joined
·
34 Posts

·
Super Moderator
Joined
·
9,992 Posts
Hi FixIt, I know it's been some time since your post, ...
I don't believe FixIt is a member anymore. Maybe some one can help you on your other thread.
 

·
Registered
2010 RAV4 V6 Limited
Joined
·
2 Posts
wondering if any one can help guide me through this.

i am trying to reset the memory of the ECT on a 2010 v6. installed techstream v.14.20.019 and it successfully detects the cable on a windows 10 (64 bit) install. i manage to do health checks etc., but when i get to the resetting the memory - i get the following error:

Reset Memory has failed. Reset Memory is not available for this vehicle.

i have tried different versions of techstream (v.13.00.022, v.12.20.024) but i get the same error each time.

went through all possible links on this subject, but could not find a real resolution



in one thread user said the he/she 'fired up the engine' - not sure what that meant since the reset is done in ON position and not with engine running. restarting the car etc. didnt help in my case.

thanks!
 

·
Registered
2010 RAV4 V6 Limited
Joined
·
2 Posts
rechecking in before i start a new thread.

anyone who has successfully reset their transmission memory, pls can you let me know what firmware version of the cable worked for you? reading more online it seems the cables with firmware 1.4.x don't support K line needed to make edits such as resetting transmission memory. if that's the case i can then look to order a cable with firmware 2.0.x which apparently supports such a function under Engine and ECU/Utility/Reset.

thanks

below are screenshots of the error i get and the cable check results:

cable-_check.jpg reset-error.jpg
 

·
Registered
Joined
·
8 Posts
This thread seems to be very long and old so I will ask a question probably already asked. I need to program the transponder in my 2007 RAV4 Limited 3 button key. I see people used Tech Stream software and a cable adapter to the car. Which TechStream software do I need specifically and which cable for my vehicle? I read somewhere that you need to purchase some kind of online subscription as well to make this work but not sure about the circumstances. Where can I purchase this software and cable? a link would be nice. Thanks in advance. I tried to use the old links earlier in this thread but none of them worked anymore.
 

·
Registered
Joined
·
8 Posts
The software is... pirated Toyota's shop software. That's because it is not for sale. Some sites offer activation serials for free:

Thanks for the reply. All the links where to get the mini VCI cable and the software are no longer valid. I was wondering if somebody has purchased the cable and software on EBay recently and has an reliable seller. Seems these cables are mass produced Chinese questionable for the most part and a lot don't even work.
 

·
Registered
Joined
·
3,628 Posts
Thanks for the reply. All the links where to get the mini VCI cable and the software are no longer valid. I was wondering if somebody has purchased the cable and software on EBay recently and has an reliable seller. Seems these cables are mass produced Chinese questionable for the most part and a lot don't even work.
All the old Techstream still works. If it does not work it is because you are not installing it right. Techstream is picky and prefer to use XP due to problems with the drivers but newer versions can work on WIN10. As for the cable most of them are made in China and should work.
 

·
Registered
Joined
·
8 Posts
I am new to this program but from my research it seems the problem is not so much with the software but trying to get the mvci cable hookup to talk to the software. I am wondering if the driver installation is any less painful now with win 10. I read that after version 12 Techstream was compatible with win 10. Does this also mean the cable drivers will work now without going through a convoluted manual install and registry hack?
 

·
Registered
Joined
·
3,628 Posts
I am new to this program but from my research it seems the problem is not so much with the software but trying to get the mvci cable hookup to talk to the software. I am wondering if the driver installation is any less painful now with win 10. I read that after version 12 Techstream was compatible with win 10. Does this also mean the cable drivers will work now without going through a convoluted manual install and registry hack?
If you use XP you do not need to do anything. Just plug and play after installing Techstream. The problem is that the drivers are the problem so it is really a software issue not hardware. The install is not straight forward for WIN10. This thread talks about it.
 

·
Registered
Joined
·
8 Posts
If you use XP you do not need to do anything. Just plug and play after installing Techstream. The problem is that the drivers are the problem so it is really a software issue not hardware. The install is not straight forward for WIN10. This thread talks about it.
You linked to this thread we are in. I dont have XP and there is no XP mode anymore in Win 10. There was in Win 7. So I have to work with win10. All these cheap chinese mvci cables all say for win xp or win 7 32bit use only. So thats the issue.
 

·
Registered
Joined
·
113 Posts
You linked to this thread we are in. I dont have XP and there is no XP mode anymore in Win 10. There was in Win 7. So I have to work with win10. All these cheap chinese mvci cables all say for win xp or win 7 32bit use only. So thats the issue.
The issue is 32 bit vs 64 bit.
The driver for FTDI chip has no problem with 64 bit, but the adapters do. I don't know if there is one that works. A number of people keep telling me it works on 64 bit, but they have not provided info about their system, so I can't believe them. I have mine working on W10 32 bit. It is dead in the water on 64 bit.
 

·
Registered
Joined
·
1,455 Posts
Thanks for the reply. All the links where to get the mini VCI cable and the software are no longer valid. I was wondering if somebody has purchased the cable and software on EBay recently and has an reliable seller. Seems these cables are mass produced Chinese questionable for the most part and a lot don't even work.
You need this. You can also find them on Amazon and elsewhere.
 
401 - 420 of 442 Posts
Top